44 Comments

  1. For anyone interested in live trading via the UI: I just released a new version (0.5.0) that allows for live trading at a few exchanges. Though it's needs some more testing, so please post issues on github if you find a problem.

  2. It took me a while to figure out how to get this working on windows 7. Everytime i tried installing npm into the exchange folder, the CMD kept coming up with errors and saying github not found in system path or something like that. so i googled about and found this https://stackoverflow.com/questions/26620312/installing-git-in-path-with-github-client-for-windows . Then npm installed into the exchange folder correctly, then started gekko UI. And its working fine, just need to find the right strategy now. Thanks for this great tool. Will donate when made some profit……………

  3. Hi I'm trying to become a member at Gekko forums but for some reason it's not sending me the confirmation email to my Gmail I don't know if you can help me thank you

  4. When I want to import a market, it say, "You currently don't have any imports running.
    " Did I not install it correctly, do I need to do something else? Right now I am completely lost.

  5. hi I am trying to install gekko on a raspberry pi 3b+
    I follow the instructions to the letter on
    https://gekko.wizb.it/docs/installation/installing_gekko_on_raspberry_pi_2_or_3.html
    I have gekko installed and the dependencies and node JS is up to date
    but it just won't launch the UI
    I:m trying to launch it directly from the pi not as a headless
    here<s the error message I get

    $ node gekko –ui
    module.js:550
    throw err;
    ^
    Error: Cannot find module '/gekko'
    at Function.Module._resolveFilename (module.js:548:15)
    at Function.Module._load (module.js:475:25)
    at Function.Module.runMain (module.js:694:10)
    at startup (bootstrap_node.js:204:16)
    at bootstrap_node.js:625:3

    I have checked in the file manager Gekko seems to be installed with lots of sub folders and documents etc
    Sorry to have a tech Q here
    I tried signing up to the forum but it told me my user name or address was associated with a spammer ?!? and locked me out
    (I swear I"m not a spammer!)

  6. UPDATE: To error "exchanges not shown". For all have the same problem, you need to install git first so the commands for broker dependencies are executed fine.

    Hey mike, I installed gekko a few months ago and it worked very fine. Now on a new computer the exchanges do not show up in the import, like some already mentioned. I tried different versions, like stable, development, release 0.6.7, but nothing worked. I also installes the broker dependencies to make sure. But when you start gekko and want to import, there is no dropdown shown. When you refresh the dropdowns are shown, but there are no entries. See https://i.imgur.com/2ZNvE7H.png Seems there is any problem.

  7. Everything seems to work for me except for when I go to import and it shows the options to select the exchanges and pairs… they are all greyed out and I can't click on them. I'm on windows 10 by the way.

  8. I followed tutorial and I have issues like from the coments below:
    1. npm install –only=production in exchange directory give errors:
    npm ERR! code ENOGIT
    npm ERR! Error while executing:
    npm ERR! undefined ls-remote -h -t ssh://git@github.com/askmike/npm-kraken-api.git
    npm ERR!
    npm ERR! undefined
    npm ERR! No git binary found in $PATH
    npm ERR!
    npm ERR! Failed using git.
    npm ERR! Please check if you have git installed and in your PATH.
    2. When I skip this step and open gekko interface it is not possible to import data, there is no dropdown menu to select exchange page.
    3. When trying to create API, only bitfinex is an option in the dropdown menu.

    I tried both branches, develop and stable, both are giving same errors.
    Please have a look. Thanks.

  9. Hi There

    Im having problems installing gekko bot i get the following

    c:UsersBrianDownloadsgekko-0.6.5gekko-0.6.5>npm install

    > sqlite3@4.0.2 install c:UsersBrianDownloadsgekko-0.6.5gekko-0.6.5node_modulessqlite3
    > node-pre-gyp install –fallback-to-build

    node-pre-gyp WARN Using request for node-pre-gyp https download
    [sqlite3] Success: "c:UsersBrianDownloadsgekko-0.6.5gekko-0.6.5node_modulessqlite3libbindingnode-v57-win32-x64node_sqlite3.node" is installed via remote

    > sinon@4.5.0 postinstall c:UsersBrianDownloadsgekko-0.6.5gekko-0.6.5node_modulessinon
    > node scripts/support-sinon.js

    Have some ❤️ for Sinon? You can support the project via Open Collective:
    > https://opencollective.com/sinon/donate

    added 243 packages from 907 contributors and audited 518 packages in 17.171s
    found 1 low severity vulnerability
    run `npm audit fix` to fix them, or `npm audit` for details

    c:UsersBrianDownloadsgekko-0.6.5gekko-0.6.5>

    how can i sort the problem

  10. ******* PROBLEM FIXED NOT MENTIONED IN THE VIDEO******* npm install

    Problem
    ********************
    npm install not recognized

    Solution
    ********************
    reboot PC required after nodejs install

    results
    *********************
    after reboot npm install worked

    My OS
    **************
    Windows 7

    Your welcome!

  11. Hey I followed your instructions first on your website, it didn't work then through this tutorial I managed to go through the end, however I do not see anything displayed. So my problem is I don't see anything, maybe something needs to be installed. When I tried to install Gekko via your website instructions, I couldn't install the second dependency in "cd exchange". Thanks if you can help

  12. when I run npm install –only=production, it works but it finds 46 Vulnerabilities,
    added 284 packages from 195 contributors and audited 730 packages in 10.628s
    found 46 vulnerabilities (14 low, 25 moderate, 7 high)
    run `npm audit fix` to fix them, or `npm audit` for details

    after fixing them when I run node gekko –ui, i get this error,
    const app = new Koa();
    ^

    ReferenceError: Koa is not defined

    Here are 2 of the 46 vulnerabilities:

    High Denial-of-Service Memory Exhaustion

    Package qs

    Patched in >= 1.x

    Dependency of f6c101c040ff8b93c4ecd3028a455c415be03eb0fbbac3904308756da4b…

    Path f6c101c040ff8b93c4ecd3028a455c415be03eb0fbbac3904308756da4b…
    > request > qs

    More info https://nodesecurity.io/advisories/29

    High Denial-of-Service Extended Event Loop Blocking

    Package qs

    Patched in >= 1.x

    Dependency of f6c101c040ff8b93c4ecd3028a455c415be03eb0fbbac3904308756da4b…

    Path f6c101c040ff8b93c4ecd3028a455c415be03eb0fbbac3904308756da4b…
    > request > qs

    More info https://nodesecurity.io/advisories/28

  13. I followed the instructions and got gekko launched but when Im going to add an API the only option available is bitfinex. How do I get Binance in the config tab to add an API key?

  14. Can anyone help with this?
    I hit enter but not Gekko UI shows up.

    module.js:549
    throw err;
    ^

    Error: Cannot find module 'moment'
    at Function.Module._resolveFilename (module.js:547:15)
    at Function.Module._load (module.js:474:25)
    at Module.require (module.js:596:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (C:UsersxxxxDownloadsgekko-developgekko-developcoreutil.js:1:76)
    at Module._compile (module.js:652:30)
    at Object.Module._extensions..js (module.js:663:10)
    at Module.load (module.js:565:32)
    at tryModuleLoad (module.js:505:12)
    at Function.Module._load (module.js:497:3)

    C:UsersxxxxDownloadsgekko-developgekko-develop>

  15. C:UsersCanlubDesktopen yeni 222gekko-develop>npm install
    npm WARN saveError ENOENT: no such file or directory, open 'C:UsersCanlubDesk
    topen yeni 222gekko-developpackage.json'
    npm notice created a lockfile as package-lock.json. You should commit this file.

    npm WARN enoent ENOENT: no such file or directory, open 'C:UsersCanlubDesktop
    en yeni 222gekko-developpackage.json'
    npm WARN gekko-develop No description
    npm WARN gekko-develop No repository field.
    npm WARN gekko-develop No README data
    npm WARN gekko-develop No license field.

    up to date in 0.112s

    C:UsersCanlubDesktopen yeni 222gekko-develop>node gekko –ui
    module.js:549
    throw err;
    ^

    Error: Cannot find module 'C:UsersCanlubDesktopen yeni 222gekko-developgek
    ko'
    at Function.Module._resolveFilename (module.js:547:15)
    at Function.Module._load (module.js:474:25)
    at Function.Module.runMain (module.js:693:10)
    at startup (bootstrap_node.js:191:16)
    at bootstrap_node.js:612:3

    Why I get this error. I don understand.

  16. does not seem to work on win 10 – fixed numerous errors, but no closer to running UI. The more errors I fix, the more that appear – and at an exponential rate. Node.js latest version=yes, python=yes, config file=yes, but too many errors to even mention here. Another 1/2 cooked github mess that works for 10% of people

  17. Do I need to repeat this every time I want to access the Gekko UI? I got it to work the first time but when I restarted my computer the URL no longer navigates to Gekko. Can anyone help?

Leave a Reply

Your email address will not be published.


*


16 + = 22